Fitbit Sync issues
Incident Report for IncentFit
Update
We are continuing to work on a fix for this issue.
Posted Sep 13, 2024 - 16:25 EDT
Identified
Our technical team has confirmed that Fitbit’s system that sends us fitness data, which includes steps and workout info, is experiencing an outage. This issue also caused delays for other apps like Garmin, Map My Fitness, and Strava. Samsung and Apple Health were not affected. You can find more information on their site: status.fitbit.com. Unfortunately, since this is an issue within Fitbit's system, we are limited in what we can do.

We are reaching out to their team hourly to see if they can correct these delays to shorten the time frame. Please subscribe to updates on this page to receive additional information.
Posted Sep 13, 2024 - 15:40 EDT
Update
Fitbit is still having issues as noted on their status page (https://status.fitbit.com), and we are unable to get data in a timely manner. Unfortunately we are still unable to get a timetable from the Fitbit team as to when we can expect a fix to this issue, but we continue to reach out to multiple support contacts for information.
Posted Sep 12, 2024 - 08:59 EDT
Monitoring
Fitbit seems to have resolved the issue but we are continuing to monitor our queue in order to continue to ensure there is no data loss. Fitbit users can expect to continue experiencing delays in syncing until the queue has been cleared.
Posted Sep 11, 2024 - 12:02 EDT
Update
We are continuing to work on a fix for this issue. Please see https://status.fitbit.com/ for more information
Posted Sep 05, 2024 - 10:23 EDT
Identified
We have identified an issue related to Fitbit's Web API that is causing delays with syncing fitness data for some individuals. We utilize this API to sync user step and activity data with our system.

We have reached out to Fitbit's Support team with detailed information in order to remedy this problem as quickly as possible.
Posted Sep 03, 2024 - 13:11 EDT
This incident affects: Services IncentFit is Dependent Upon (FitBit, Google Fit, Garmin, Validic).