Users Cannot Add Document or Receipts

Incident Report for IncentFit

Resolved

This incident has been resolved.
Posted Mar 08, 2022 - 11:40 EST

Identified

We are working to fix this issue. Any users can submit receipts to support@incentfit.com and our team will upload on their behalf once corrected.
Posted Mar 08, 2022 - 11:05 EST
This incident affected: Web Application and Mobile Application.