Resolved: IncentFit Recharge Mobile login issues

Incident Report for IncentFit

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 11:02 EST

Monitoring

All mobile app login errors were resolved as of 2/18 at 2:45 PM EST. If you are still experiencing issues logging in, please delete the IncentFit Recharge app and download the latest version from the App Store.
Posted Feb 18, 2026 - 14:50 EST
This incident affected: Mobile Application.