Site Loading Slowly

Incident Report for IncentFit

Resolved

This incident has been resolved.
Posted May 02, 2022 - 17:40 EDT

Investigating

We are receiving reports of slow loading times across the site. We are currently investigating this issue.
Posted May 02, 2022 - 15:03 EDT
This incident affected: Web Application, Mobile Application, and API.