SSO Login Outage

Incident Report for IncentFit

Resolved

This incident has been resolved.
Posted Jun 14, 2023 - 13:06 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 14, 2023 - 12:42 EDT

Investigating

We are investigating reports of SSO no longer working on web and mobile app. Users who are still signed into the mobile app will not experience any issues. For employees who are submitting documentation to us, please email us at uploads(at)incentfit(dot)com.
Posted Jun 14, 2023 - 11:31 EDT
This incident affected: IncentFit Services (Login).