IncentFit App Stuck on Splash Screen

Incident Report for IncentFit

Resolved

We have confirmed that the new iOS app is working as expected and we have heard no new reports of this issue.
Posted Jul 08, 2022 - 11:52 EDT

Monitoring

The updated iOS application has fixed the problem and we are monitoring the results.
Posted Jul 05, 2022 - 11:15 EDT

Update

A release for this issue has been instituted, and the new app will be available Tuesday at the latest.
Posted Jul 01, 2022 - 17:55 EDT

Identified

Our team has received reports that the IncentFit app becomes stuck on the loading/splash screen for both iPhone and Android users. For some users "killing" and reopening the app will allow them to access the app. Our team is working on a fix for this. All users can restart the app, or log in from the web app. This issue does not affect any saved data or other parts of the system.
Posted Jun 01, 2022 - 16:38 EDT
This incident affected: Mobile Application.