504 Errors Accessing Site

Incident Report for IncentFit

Resolved

This incident has been resolved.
Posted Mar 21, 2022 - 11:29 EDT

Investigating

We are currently investigating. If you have a document to submit please emails this to uploads@incentfit.com or to our support team at support@incentfit.com. Subscribe on this page for updates.
Posted Mar 21, 2022 - 11:27 EDT
This incident affected: Web Application, Mobile Application, and API.