Site Loading Slowly

Incident Report for IncentFit

Resolved

This incident has been resolved.
Posted Oct 04, 2021 - 10:55 EDT

Identified

Our team has received reports of website slowness. Users may see a 504 error. Users can refresh the site to reload. We are investigating these delays and should have the issue resolved shortly.
Posted Oct 04, 2021 - 10:22 EDT
This incident affected: Web Application and Mobile Application.